
11/2/2024

1

CHAPTER 5: DIGITAL CONTENT CREATION

MODERN DIGITAL SKILLS 

1
© All Rights Reserved The University Of Jordan 

The University of Jordan King Abdullah II School of 
Information Technology

CONTENTS
1. What is Digital Content Creation? 
2. Steps to successful Digital content 

creation
3. Steps to Create a Digital Content 

strategy
4. Some useful tools and applications 

for Digital content creation
• Public portals
• Office Apps
• Google Apps
• Email
• Cloud Storage
• Forms

5. Digital content creation some useful 
tools and Applications
• One Drive
• One Note
• MS Forms

© All Rights Reserved The University Of Jordan 2



11/2/2024

2

What is Digital Content Creation?
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What is Content? Any type of INFORMATION, that users/consumers 
can get VALUE from

What is Digital Content?
Information in a computerized format such as text, 
image, audio, or video which is created and shared by 
digital devices such as PCs or phones.  

Who is Digital Content Creator? A person who can develop (create) digital 
content using special applications or tools

What is Digital Content Creation? Turning the ideas of the content creator into a 
digital content.

Who is the ethical Digital Content Creation? Responsible digital creation that provides credible 
ideas and respects copyright and privacy.

Steps to successful Digital Content Creation
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Determine 
the purpose 
of content

1

Create 
useful 

content

2

Promote 
content on 

social media

3

Use photos 
and 

Multimedia

4

Implement 
an SEO 

program

5

Track and 
Analyze
content 

6

 Once you have identified your target audience, Follow this Strategy
to create your successful content:

(Search Engine Optimizer)
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Steps to Create a Digital Content strategy
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3) Promote
Promote content on social media platforms. 

* Distribute your content across different social media platforms, 
* Customize your content for each platform to encourage your 
followers to follow from different networks. 

2) Create
Create useful and quality content 

* The more useful the content, the easier for people to relate it to 
their own views and share it within their networks

1) Determine Determine the purpose to improve the likelihood of your content 
reaching the desired results.

Steps to Create a Digital Content strategy
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6) Track 
Track and analyze content because It’s important to stay aware of 
your ranking in the best search engines and continually aim to 
improve these rankings. 

5) Implement

Implement an SEO program.
SEO (Search Engine Optimizer): is a strategy of organizing your content by topic 
to improve the chance of appearing in search results
*Powerful SEO ensures that your content is relevant and valuable to your 
target audience
* Powerful SEO helps you identify the right keywords to use so the content can 
be found by people who are searching for that information

4) Utilize Utilize multimedia in your content like images, audios, and videos.

*Content with attractive images is likely to get more views
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Some useful tools and Applications for Digital Content Creation
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Public Portals

• YouTube (from Google)
• Free video distribution

• Wikipedia
• Similar to a digital online 

publicly-written  
Encyclopedia

Office Apps 

• MS Word
• MS Excel
• MS PowerPoint
• One Note

Google Apps 

• Docs
• Sheets
• Slides

Some useful tools and Applications for Digital Content Creation
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E-mail

•Outlook (Microsoft)

•Gmail (Google)

•Use it for 
electronic 
communication by 
sending and 
receiving messages 

Cloud Storage

• OneDrive (Microsoft)

• Drive (Google)

• Dropbox (Dropbox)

• Use it for storing, 
accessing, and sharing 
files online

Forms

• Ms Forms (Microsoft)

• Google Forms (Google)

• Use it for Online surveys 
and statistical analysis
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Digital Content Creation
Some useful tools and Applications: One Drive 
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• One Drive A cloud storage service from Microsoft that enables users to store 
files online, access them from any device, and share them securely with others

• Uses of One Drive:
• File Storage: Store documents, photos, and videos online, freeing up space on 

local devices.
• File Sharing: Easily share files or folders with others by sending links
• Collaboration: Work on documents and projects in real-time with others, making 

it easy to edit and update files simultaneously. 

Let's watch this video about OneDrive from YouTube 

Digital Content Creation
Some useful tools and Applications: One Drive 
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Type : https://www.office.com
Enter your Email address and password

The following window will appear welcoming you to 
Microsoft 365



11/2/2024

6

Digital Content Creation
Some useful tools and Applications: One Drive 

© All Rights Reserved The University Of Jordan 11

Click  the App Launcher (the dots ) then choose OneDrive

Digital Content Creation
Some useful tools and Applications: One Drive 
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The following window of the OneDrive will appear
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Digital Content Creation
Some useful tools and Applications: One Drive 
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Click on My files to display your files:

Digital Content Creation
Some useful tools and Applications: One Drive 
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Click on My files to display your files , then choose the file Document. Click on the three dots …
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Digital Content Creation
Some useful tools and Applications: One Drive 
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1. Share : Allows you to share the folder with People via email.
2. Copy Link : Copy the folder or File link ,to share it with others.
3. Manage Access : Manage the privileges given to people 
4. Download: to download your files and folders.

1

2

3

click

4

Digital Content Creation
Some useful tools and Applications: One Drive 
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Digital Content Creation
Some useful tools and Applications: One Drive 
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Can Make any changes and Download it. 

Can’t make any changes but can 
Download it. 

Can’t make any changes and can’t 
Download it. 

Determine with Whom you want to 
share the File or Folder 

Send Notification via email containing 
the file or folder Link

Digital Content Creation
Some useful tools and Applications: One Drive 
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Click Shared , you will see that Document file is shared By you to other people with specified granted access
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Digital Content Creation
Some useful tools and Applications: One Drive 
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Click on Add new to upload a File or a Folder or create a New File or Folder .

Digital Content Creation
Some useful tools and Applications: One Drive 
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Click on Add new to upload a File or a Folder

To Create a folder in your Drive .

upload a File from your device .
upload a Folder from your device.

Create a MS Office File 
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Digital Content Creation
Some useful tools and Applications: One Note
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• One Note is a digital note-taking application from Microsoft that allows users 
to create, organize, and share notes (especially for university lectures) in a 
flexible and collaborative way. 

• Uses of One Note:
• Note Taking: Capture text, images, audio, and video notes in a single place, 

making it easy to organize notes into notebooks, sections, and pages for easy 
navigation and retrieval.

• To-Do Lists: Create to-do lists and checklists to keep track of tasks and deadlines 
within your notes. 

Let's watch this video about One Note from YouTube   

Let's watch: To Do List about One Note from YouTube 

Digital Content Creation
Some useful tools and Applications: One Note
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Type : https://www.office.com
Enter your Email address and password
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Digital Content Creation
Some useful tools and Applications: One Note
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Click the App launcher then click OneNote

Digital Content Creation
Some useful tools and Applications: One Note
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Click on : Blank notebook  
The New notebook dialog box appears, 
type the name of the notebook , for 
example Training then click create to 
create a notebook
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Digital Content Creation
Some useful tools and Applications: One Note

© All Rights Reserved The University Of Jordan 
25

The Training notebook gives you the option to select sections and pages within those sections. At the top there is the ribbon 
with tools and at the bottom you have Add section and Add page. The  notebook is empty so now will add sections and pages.

Digital Content Creation
Some useful tools and Applications: One Note
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To add a section click Add section. A box will appear then type the name of the section for example Word. Then click OK
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Digital Content Creation
Some useful tools and Applications: One Note
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The Word section is created .The section has an Untitled Page.

Word section

Digital Content Creation
Some useful tools and Applications: One Note
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For the fist page type the name of the page Word Level1 then add another page name it  Word Level2
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Digital Content Creation
Some useful tools and Applications: One Note
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Repeat the same steps to add another section named Excel with two pages named Excel Level 1 and Excel Level 2.

Digital Content Creation
Some useful tools and Applications: One Note
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You can add  pictures from Insert tab You can add  files from Insert tab either as an 
attachment or as a printout 



11/2/2024

16

Digital Content Creation
Some useful tools and Applications: One Note
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You can add  tables from Insert tab You can add  audio and video from Insert tab 

Digital Content Creation
Some useful tools and Applications: One Note
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Add to the Word Level 1 page in the Training Notebook a picture, a text, a table, a link to a video, an audio recording and a 
file as an attachment  as shown below.
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Digital Content Creation
Some useful tools and Applications: One Note
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To create a To Do list  to the Word Level 2 page in the Training Notebook do the following: 
• Type the list you want to do 
• Select the list
• From Home tab, click Tags and select To Do
• Check boxes will appear beside each item in the list

Digital Content Creation
Some useful tools and Applications: One Note
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Add a third page to the Word section , name it Word Level 3. Add any file from your choice as a printout.  
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Digital Content Creation
Some useful tools and Applications: One Note
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• Type the following paragraph to the page Word Level 2 :
OneNote is a digital note-taking app that provides a single place for keeping all of your notes, research, plans, and 
information — everything you need to remember and manage in your life at home, at work, or at school. In OneNote, 
notebooks never run out of paper.  
• From Home tab, format this paragraph using the commands in the following toolbar:

Font Type

Font Size

Bullets
Numbering

Paragraph Alignment    
and 
paragraph Spacing

Font Style

Underline

Digital Content Creation
Some useful tools and Applications: MS Forms
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• MS Forms is used to create sharable online forms such as Online surveys, 
polls, and quizzes. 

• Use MS Forms to:
1. Create a form with different types of questions
2. Share the form with others like:

• Responders, who  answer the form and send it back to you
• Collaborators, who can edit/add/delete contents from the form

3. Collect and analyze responses: get a report of the results of by the built-in 
analytics in MS Forms which gives statistical insights into responses.

4. Share back results with responders
Let's watch this video about MS Forms from YouTube  
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Digital Content Creation
Some useful tools and Applications: MsForms
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Type : https://www.office.com
Enter your Email address and password

Digital Content Creation
Some useful tools and Applications: MsForms
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Click on 
Apps
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Digital Content Creation
Some useful tools and Applications: MsForms
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To create a Form  Click on  New Form 

Digital Content Creation
Some useful tools and Applications: MsForms
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Types of questions

Form Title
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Digital Content Creation
Some useful tools and Applications: MsForms
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Click on Untitled Form then Write the Form Title and Form Description :

Digital Content Creation
Some useful tools and Applications: MsForms
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Digital Content Creation
Some useful tools and Applications: MsForms
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If Required enabled means that the field 
must be filled by the respondent. 

Text Question Type

Result 

Digital Content Creation
Some useful tools and Applications: MsForms
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Text Question Type

Result 
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Digital Content Creation
Some useful tools and Applications: MsForms
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Choice Question Type

Multiple answers when enabled allows 
the respondent to select more than one 
choice.

Result 

Digital Content Creation
Some useful tools and Applications: MsForms
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Result 

Date Question Type

Calendar
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Digital Content Creation
Some useful tools and Applications: MsForms
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Rating Question Type

Result 

Digital Content Creation
Some useful tools and Applications: MsForms
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Upload A File Question Type

Result 

Here you determine the number 
of files that can be uploaded.

The Single file Size 
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Digital Content Creation
Some useful tools and Applications: MsForms
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Digital Content Creation
Some useful tools and Applications: MsForms
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Computer Preview Mobile Preview
Click on Preview to see how the Form appears:
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Digital Content Creation
Some useful tools and Applications: MsForms
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You can Copy Link and Share it

Invite People to Via Email

Digital Content Creation
Some useful tools and Applications: MsForms
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https://forms.office.com/Pages/ResponsePage.aspx?id=ul1ABT
w3IE6jDj5vz1B8_llXOtlAT5xGqUZoiaPYJ9VUNkpENlI2MDRIMFpZ
NUZTWElBQ0xCSlNRVy4u

https://forms.office.com/r/G43qsunjN7

The Form Link after Shorten URL
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Digital Content Creation
Some useful tools and Applications: MsForms
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Digital Content Creation
Some useful tools and Applications: MsForms
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The Created Form 
Listed in your 
Forms.
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Digital Content Creation
Some useful tools and Applications: MsForms
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https://forms.office.com/r/G43qsunjN7

Please use  the following URL to Enter to the Form :


